Media Wiki Google Login


#1

@Bez per your email to the Google Group, I’m looking at installing the Google Login extension to wiki.ithacagenerator.org, looks pretty straightforward.


#2

OK, so this is going to require an upgrade of MediaWiki from 1.21.1 (current level) to at least 1.25… starting on that now.


#3

@Bez I think I’ve installed and set up that Google Login plugin correctly, but when I login with Google, I get;

The supplied credentials are not associated with any user on this wiki.

If you read in some detail here. And I found this discussion thread as well, which seems to suggest there is a problem they are working on

Yes, like I said: GoogleLogin for MediaWiki 1.27 does not allow you to register an account with Google anymore (at least not in the way you expect, it seems). If you want the option to create a new wiki account, if the google account is not connected with one already, you need to use an older version (which I linked in my answer before this one). Otherwise, you first have to create a wiki account and then connect it with your google account in order to login with your google account…


#4

Aw, foo. Sounds like the plan is/was to shift the account creation functionality to AuthManager (the MediaWiki authentication system), but it hasn’t happened yet. Thanks for taking a crack at it, though.


#5

Eureka, I’ve got it. I was able to install the older version of the plugin and it worked for me. I had to jump through a bunch of hoops to do it, but I think we’re in business. I just logged in and linked it to my existing wiki account even. For anyone who might be interested, I had to install the Google API Client separately using composer, which was a new thing to me, to get it to work.

As a bonus, we’re running the latest Media Wiki now (1.28)… @Bez if you wouldn’t mind poking around to make sure I didn’t leave bork anything in the process content or plugin-wise that would be cool. I installed a different breadcrumb plugin, for example, since the one we previously had in there is no longer being maintained.


#6

Sure, I’ll kick the tires over the weekend.


#7

Finally got around to poking at the Wiki.


#8

@Bez, Thanks I’ll try and sort these out this weekend


#9

@Bez, I think the image thumbnails issue is solved, indeed a permissions issue. Fixed the Verilog page problem as well, needed to update the SyntaxHighlighter plugin to the latest. Look good to you?


#10

I just updated the Digital Ocean server that hosts the Wiki and Wordpress sites from Ubuntu 14.04 to 16.04. Sorry if anyone experienced any disruption in the last hour or so, but I’ve poked around a bit and everything seems to be fine now. Let me know if anyone finds any problems and I will persevere to fix them. In a worst case scenario, I have a snapshot of the server that we can role back to if absolutely necessary (which, by the way, is one of the best reasons for us not to do the host-it-yourself thing).